2014 Altima - Nissan Forum - Nissan Enthusiast Forums


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 11-26-2017, 12:33 AM
Junior Member
Thread Starter
 
Join Date: Nov 2017
Posts: 1
Default 2014 Altima

Hello folks,

So I am car noob, but recently I had damage when a rock spin under my car and damaged my transmission fluid pan. My dealership replaced it, and seems like it is running good. But I attached a picture and seems like that silverish part under black engine gets quiet hot, like I cant touch it, even if I drive like 4miles. Is it normal? What part is it?

No alarms on dashboard, and temperature stay cold and below 50%.


Sal
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New Roof Rack for 2014-2015 Nissan Rogue carid Official Sponsor Sales & Group Buys 0 10-02-2015 09:11 AM
WeatherTech® Window Deflectors for 2014 Nissan models! carid Exterior 1 03-25-2015 10:41 AM
BAKFlip G2**Must see, promo ends 3/31/2014** HitchAnything Official Sponsor Sales & Group Buys 0 03-06-2014 04:45 PM
2014 Rogue mag318 Nissan Rogue 0 10-07-2013 03:10 PM


Tags
altima, heating, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 09:56 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.