Go Back  Nissan Forum - Nissan Enthusiast Forums > Nissan Cars > Nissan Altima
Reload this Page >

1996 Nissan Altima rough idle, heavy vibration, and running hot after tune-up

Nissan Altima This mid sized entry is been among the leaders in its class thanks to its powerful engine and roomy interior.

1996 Nissan Altima rough idle, heavy vibration, and running hot after tune-up

  #1  
Old 05-12-2019, 12:41 PM
Junior Member
Thread Starter
Join Date: May 2019
Posts: 1
Default 1996 Nissan Altima rough idle, heavy vibration, and running hot after tune-up

Hi, hope someone can help.
I have a 1996 Nissan Altima 2.5L, about 70k miles. inherited from my grandmother (low miles because she just used to to go to the grocery store and doc appointments).

After having it two years and about 12k miles later, I brought it to a mechanic for a tune-up, and to look into sluggish acceleration response, and delayed shifting under load,
The car ran well, idle was consistent at 750, and so smooth I didnt even know the car was on.

I get it back and now it runs REALLY rough, car vibrates heavily, especially when in gear, shaking the steering wheel and mirrors to a blur. It sounds like a diesel, the idle is inconsistent and searches, (900-750-500-700-1000-750-600 etc) especially when warm, and stopped at a stop light... it runs much hotter than it did before I brought it in. (temp guage used to be at 1/4, now it sits at 1/2 and get hotter under heavy load.) if i shift into park, it drops almost to the point of stalling. I've noticed a slight hissing when my foot is barely on the accelerator cruising at consisent speed.
no engine light, no codes. today I noticed that the idle will drop more when I turn on the headlights, or the air-conditioning.

at the tune-up:
-replaced spark plugs
-electronic fuel injection service with throttle body cleaning

I brought it back a week later, due to the worsened condition, vibration and additional heat.
They looked at it again...
"we went through it, and couldnt find anything wrong with the engine, but the rear engine mounts needed to be replaced."
-replace the rear engine mounts.... get it back, the vibration is even worse, and the car still runs terrible.
I dont think the inconsistent idle would have anything to do with the engine mounts, vibration, maybe. something happened.

ideas or advise?
Thanks


 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
vid_ro
Nissan Altima
1
01-20-2009 10:18 PM
Umpire727
Nissan Altima
9
06-08-2007 08:36 PM
rpousjr
PRIVATE For Sale / Trade Classifieds
2
08-28-2006 04:18 PM
jakerazer
Nissan Pathfinder
2
06-30-2006 12:21 AM


Thread Tools
Search this Thread
Quick Reply: 1996 Nissan Altima rough idle, heavy vibration, and running hot after tune-up


Advertising

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Featured Sponsors
Vendor Directory